インターネットエクスプローラーでダウンロードできない

お客様から「インターネットエクスプローラー(IE.11)でYahooのページでログインしてもID、パスワードが記憶されない、、、ファイルのダウンロードが出来ない、、、」とご相談があり、パソコンを持ち込んで頂きました。

比較的簡単に直るだろうと思っていたら、、、

トンでもない、、、

久しぶりに苦労してしまいました(^_^;)

今後のサポートに活かすため、その顛末を記録したいと思います。

最初に動作を確認・・・IEを開きYahooIDとパスワードを入力いただき、
□ ログインしたままにするにチェックをつけ、いったんIEを閉じます。

そして再度IEでYahooページを開くと、お客様のおっしゃる通り
ログインされておらず、ログインボタンをクリックしないといけません。
ログインボタンをクリックすると「ID、パスワード」は出てくるのでCookieは大丈夫??なようです。

もうひとつの「ダウンロードできない」症状も確認しました。
適当なファイルをダウンロードすると保存先の指定が出来るのですが、保存するをクリックしても何の反応もありません。

いろいろ調べている間に「Silver lightのバージョンが古いため、、、」と言うメッセージが出たのでまずは、Silver lightを最新のバージョンへ、アクロバットリーダーも古いため、最新のバージョンへアップデートしました。

そして、、、

トラブルシューティング<その1>

IEのリセットを行う

やはり一番最初に行うのはIEのリセット、これでIEの結構トラブルが解決します。
歯車マークをクリック→インターネットオプション→「詳細設定」タグ→「リセット」をクリック

そして、念のためパソコンも再起動
動作確認・・・ところが状況は変わらず。

インターネットオプションからインターネット一時ファイルの保存先を確認したところ、保存先がなく、しかも容量も0になっていたので保存場所を基本的なフォルダ(Temporary Internet Files)に設定してIEを再起動、そして動作確認したところ状況が変わらないので再度保存先をチェック、すると設定した値は戻っていて保存先がない状態に、、、

キャプチャ.jpg

レジストリエディッター「regedit.exe」を実行してインターネット一時ファイルの保存先をレジストリで再設定
再起動、、、状況は変わらず

キャプチャ2.JPG

トラブルシューティング<その2>

ウイルス・スパイウェアをチェック
こういったケースの場合、ウイルスやスパイウェアが入っていることで不具合が発生するケースも考えれるので
ウイルスおよびスパイウェアをウイルスバスターといつものスパイウェアチェックソフトでチェック、結果はウイルス・スパイウェア両方とも検出はされませんでした。

トラブルシューティング<その3>

IE.11の修復を試してみる・・・状況は変わらずで

IE.11のアンインストールしました。
念のため、IE.10で動作確認したところ状況は変わらず。
IE.11だけの問題ではなさそうなので、ひとまずIE.11のインストールは保留にしました。

トラブルシューティング<その4>

ウイルスソフトが原因の可能性も否定できないので
念のため、ウイルスバスターをアンインストール・・・状況は変わらず

トラブルシューティング<その5>

IE.10 アンインストールすることでIE.9 に戻りますが、IE.9 の状態で動作を確認したところ、状況は変わらずでしたので

さらに

IE.9 をアンインストール・・・IE.8に戻しました。
動作を確認したところ、インターネット一時ファイルの保存先は元に戻り、ダウンロードもOK、そしてYahooログインも設定が保存されて、不具合が直り、
後はIE.11を再度インストールしてウイルスソフトを戻すだけと思いきや、、、、

マイクロソフトのIE.11のダウンロードページから個別にインストール
ダウンロード・インストールと順調に進んでいるかのように見えたのもつかの間、

「インストールが正常に出来ませんでした」とのメッセージ
ここからさらにWindowsアップデートも含め、新たな戦いが始まりました、、、

それならば
通常にWindowsアップデートで更新しようとWindowsアップデートの「更新プログラムの確認」を見ると、、、

「現在サービスが実行されていないため、Windows Update で更新プログラムを確認できません。このコンピュータの再起動が必要な場合があります。」とメッセージが、、、

キャプチャ7.jpg

トラブルシューティング<その6>

再起動しても状況は変わらずでしたので、
実際にサービスが実行されていないのかを確認!

スタートメニューの検索ボックスに「サービス」と入力し、Enterキーを押すとコンポーネントサービスが立ち上がります。
または、コントロールパネル→管理ツールをクリックでも立ち上がります。

右メニューの「サービス」をクリック→左メニューの中の「Windows Update」項目を選択右クリック→プロパティで確認
→スタートアップの
サービスが動作しているか確認・・・動作していました。

参考サイト→http://pasofaq.jp/windows/update/disablewuauserv.htm

キャプチャ6.jpg

いろいろネットで検索していると!

東芝のページで参考になるサイトがありました。

http://dynabook.com/assistpc/faq/pcdata/013378.htm

このサイトにあるように
repairt.batと言うバッチファイルを作成して「管理者で実行」Windows Update を行う際に使用する各設定を初期化しました。

状況・・・回復せず、、、 まだまだ作業が続きます(^_^;)

続きは次回に、、、